8000 minor #16634 Use a better name than "class Foo" (BafS) · symfony/symfony-docs@1dcc3cd · GitHub
[go: up one dir, main page]

Skip to content

Commit 1dcc3cd

Browse files
committed
minor #16634 Use a better name than "class Foo" (BafS)
This PR was submitted for the 5.4 branch but it was merged into the 4.4 branch instead. Discussion ---------- Use a better name than "class Foo" It took me a while to figure out what represent `class Foo` <!-- If your pull request fixes a BUG, use the oldest maintained branch that contains the bug (see https://symfony.com/releases for the list of maintained branches). If your pull request documents a NEW FEATURE, use the same Symfony branch where the feature was introduced (and `6.x` for features of unreleased versions). --> Commits ------- 1b8d52d Use a better name than "class Foo"
2 parents d96fcfe + 1b8d52d commit 1dcc3cd

File tree

1 file changed

+2
-2
lines changed

1 file changed

+2
-2
lines changed

components/event_dispatcher.rst

Lines changed: 2 additions & 2 deletions
Original file line numberDiff line numberDiff line change
@@ -499,9 +499,9 @@ is dispatched, are passed as arguments to the listener::
499499
use Symfony\Contracts\EventDispatcher\Event;
500500
use Symfony\Contracts\EventDispatcher\EventDispatcherInterface;
501501

502-
class Foo
502+
class MySubscriber
503503
{
504-
public function myEventListener(Event $event, $eventName, EventDispatcherInterface $dispatcher)
504+
public function myEventListener(Event $event, string $eventName, EventDispatcherInterface $dispatcher)
505505
{
506506
// ... do something with the event name
507507
}

0 commit comments

Comments
 (0)
0