CCNA Sec Slides
CCNA Sec Slides
CCNA Sec Slides
• Classifying Vulnerabilities.
• Policy flaws
• Design errors
• Keys.
• Encryption Methods.
• Stream Ciphers (cipher digit stream).
• A symmetric key cipher, where each bit of plaintext data to be encrypted is done 1 bit at a time against the bits
of the key.
• Block Ciphers.
• A symmetric key cipher that operates on a group of bits called a block.
• May take a 64-bit block of plain text and generate a 64-bit block of cipher text.
• Examples:
• Digital Encryption Standard (DES)
• Triple Digital Encryption Standard (3DES)
- Advanced Encryption Standard (AES)
- Blowfish
- International Data Encryption Algorithm (IDEA)
• Block ciphers may add padding in cases where there is not enough data to encrypt.
• Key algorithms.
• Symmetric.
• Uses the same key to encrypt the data and decrypt the data.
• Examples:
- DES
- 3DES
- AES
- IDEA
- RC2, RC4, RC5, RC6
- Blowfish
• Used for most of the data that we protect in VPNs today.
• Much faster to use a symmetrical encryption algorithm.
• The more difficult the key, the more stronger encryption.
• The minimum symmetric key length should be at least 128 bits.
• Asymmetric.
• An example of an asymmetric algorithm is public key algorithms.
• We use two different keys (key pair) that mathematically work together as a pair.
• These keys are the public key and the private key.
• We use asymmetric algorithms for things such as authenticating a VPN peer or generating keying material that
we could use for our symmetrical algorithms.
CCNA Sec Page 12
•
we could use for our symmetrical algorithms.
• The public key is published and available to anyone who wants to use it.
• The private key is known only to the device that owns the public-private key pair.
• Examples of asymmetrical algorithms.
• RSA (Rivest, Shamir, and Adleman).
• The primary use of this asymmetrical algorithm today is for authentication.
• The key length may be from 512 to 2048 (Recommended 1024).
• DH (Diffie-Hellman).
• Allows devices to establish shared secret keys over an untrusted network.
• This key will be used with symmetric algorithms as 3DES, AES.
• ElGamal.
• Asymmetrical encryption system is based on the DH exchange.
• DSA (Digital Signature Algorithm).
• Was developed by the U.S. National Security Agency.
• ECC (Elliptic Curve Cryptography).
• OTP (one-time pad).
• A good example of a key that is only used once.
• To encrypt a 32-bit message, we use a 32-bit key, also called the pad , which is used one time only.
• Each bit from the pad is mathematically computed with a corresponding bit from our message, and the results
are our cipher text.
• The pad must also be known by the receiver if he wants to decrypt the message.
• Hashes.
• Hashing is a method used to verify data integrity.
• It is a one-way function.
• The result of the hash is a fixed-length small string of data called (digest or message digest or hash).
• The three most popular types of hashes:
- Message Digest 5 (MD5): This creates a 128-bit digest.
- Secure Hash Algorithm1 (SHA-1): This creates a 160-bit digest.
- Secure Hash Algorithm 2 (SHA-2): Options include a digest between 224 bits and 512 bits.
• Hashed Message Authentication Code (HMAC).
• It includes in its calculation a secret key.
• Digital Signatures.
• Prove that you are who you say you are.
• Keyspace.
• Refers to all the possible key values for a key.
• Next-Generation Encryption Protocols.
• Elliptic Curve Cryptography (ECC).
• Replaces RSA signatures with the ECDSA algorithm.
• Replaces the DH key exchange with ECDH.
• AES in the Galois/Counter Mode (GCM) of operation.
• ECC Digital Signature Algorithm.
• SHA-256, SHA-384, and SHA-512.
• IPSec.
• A collection of protocols and algorithms used to protect IP packets at Layer 3.
• Provides:
- Confidentiality through encryption.
- Data integrity through hashing and HMAC.
- Authentication using digital signatures or using a pre-shared key (PSK) that is similar to a password.
• Types of IPSec.
CCNA Sec Page 13
• Types of IPSec.
• Encapsulating Security Payload (ESP).
• Can do all the features of Ipsec.
• Authentication Header (AH).
• Can do many parts of the IPsec objectives, except encryption of the data.
-------------------------------------------------------------------------------------------------------------------
• Encryption algorithms for confidentiality: DES, 3DES, AES.
• Hashing algorithms for integrity: MD5, SHA.
• Authentication algorithms: Pre-shared keys (PSK), RSA digital signatures.
• Key management: for ex. Diffie-Hellman (DH), which can dynamically generate symmetrical keys.
• SSL.
• There is not an IPsec client or software currently running on everybody’s computer.
• Even if there were, not everyone has a certificate or a PSK for authentication.
• Every web browser on every computer supports SSL.
• Public Key Infrastructure (PKI).
• Key pair.
• A set of two keys that work in combination with each other as a team.
• The public key may be shared with everyone.
• The private key is not shared with anyone.
• CA (Certificate Authority).
• A computer or entity that creates and issues digital certificates.
• Inside the certificate the ip and the FQDN and the public key for the issuer.
• In the final certificate is a URL that other devices can check to see whether this certificate has been revoked and
the validity date.
• Most web browsers maintain a list of the more common trusted public CA servers.
• Root certificate.
• Contains the public key of the CA server and the other details about the CA server.
• Identity certificate.
• Similar to a root certificate, but it describes the client and contains the public key of the client.
• ASDM > Wizards > VPN Wizards > Site-to-Site VPN Wizard .
show ip protocols
• Implement Routing Update Authentication on BGP.
• R(config)# router bgp AS-n
• R(config-router)# neighbor 1.1.1.2 remote-as other-router-as (if the same, iBGP will be used)
• R(config-router)# network 10.0.0.0 mask 255.0.0.0
• R# sh ip bgp summary
• R(config-router)# neighbor ip password key
• R# show ip bgp neighbors
• Global.
• Like Real.
• Globally unique.
• Routable with no modification.
• Configured automatically or manually.
• Have the first four characters in the range of 2000 to 3FFF
• Anycast.
• A shared global unicast address to multiple devices.
• An IP address that appears more than one time in a network.
• Usually, two DNS servers, if they both use the same anycast address, are functional to the users.
• ----------------------------------------------------------------------------------------------------------------------------- -
• R1# show ipv6 interface fa0/1
• Configuring IPv6 Routing.
• IPv6 dynamic routing protocols:
- RIP, called RIP next generation (RIPng)
- OSPFv3
- EIGRP for IPv6
• To include interfaces of the routing process, you use interface commands.
• For EIGRP, you also need to issue the no shutdown command in EIGRP router configuration mode.
• To enables IPv6 routing.
• R(config)# ipv6 unicast-routing
• NAT Terminology.
• Inside local.
• The IP configured on an inside host, such as PC1.
• Inside global.
• The mapped/global address that the router is swapping out for the inside host during NAT.
• Outside local.
• This is the mapped address of the outside device.
• Outside global.
• The real IP configured on an outside host, such as the IP on Server A.
• Dynamic NAT.
• Maps multiple private ips to multiple public ips randomly.
• Uses Access-list to select allowed addresses for dynamic translation.
• Define Access-list for local addresses to be translated.
• R(config)# access-list 10 permit 60.0.0.0 0.255.255.255
• Create a pool of global addresses to be translated.
• R(config)# ip nat pool pool1 5.5.5.1 5.5.5.20 netmask 255.0.0.0
• Enable dynamic NAT between IPs in the ACL and the global pool.
• R(config)# ip nat inside source list 10 pool pool1
- This means, translate permitted addresses in that Access-list to that pool
• Define the local NAT interface.
• R(config-if)# ip nat inside
CCNA Sec Page 59
• R(config-if)# ip nat inside
• Define the outside NAT interface.
• R(config-if)# ip nat outside
• To view NAT translations on Router.
• R# show ip nat translation
• Static NAT.
• Allow one-to-one mapping of local and global addresses.
• For hosts which must have consistent ip accessible from the Internet. (servers).
• Define translated addresses (local & global).
• R(config)# ip nat inside source static 60.0.0.1 5.5.5.1
• Define the local NAT interface.
• R(config-if)# ip nat inside
• Define the outside NAT interface.
• R(config-if)# ip nat outside
• To view NAT translations on Router.
• R# show ip nat translation
• Supports features, as stateful inspection, application inspection, URL filtering, DoS mitigation.
• CBAC & Zones models can be enabled concurrently on a router.
• Interface cannot be configured as a zone member and configured for IP inspection simultaneously.
• Interfaces that have not been assigned to a zone can still use CBAC stateful inspection.
• ASDM
• Pre-configurations.
• Ciscoasa(config)# http server enable
• Ciscoasa(config)# http host-ip|network-id mask interface-name
• Ciscoasa(config)# username name password the-password (or use blank user and enable password)
• Ciscoasa(config)# interface g0/0
• Ciscoasa(config-if)# ip add 30.0.0.100 255.0.0.0
• Ciscoasa(config-if)# no shut
• Ciscoasa(config-if)# nameif name
• Ciscoasa(config-if)# security-level 100
• Ciscoasa# copy tftp: flash: asdm-647.bin
• Open browser, https://ASA-ip , Install ASDM Launcher and Run ASDM
CCNA Sec Page 69
• Open browser, https://ASA-ip , Install ASDM Launcher and Run ASDM
• To view interfaces ip addresses.
• Ciscoasa# sh interface ip brief
• Ciscoasa# sh ip address
• Ciscoasa# sh nameif
• To use PAT, use Dynamic PAT (Hide) mode and then select the outside interface.
• Sensor Platforms.
• A dedicated IPS appliance, such as the 4200 series.
• Software running on the router in versions of IOS that support it.
• A module in an IOS router, such as the AIM-IPS or NME-IPS modules
• A module on an ASA firewall in the form of the AIP module for IPS.
• A blade that works in a 6500 series multilayer switch.
• Cisco FirePOWER 8000/7000 series appliances.
• Virtual Next-Generation IPS (NGIPSv) for Vmware.
• ASA with FirePOWER services.
• Alarm type.
• WCCP Registration.
• During the WCCP registration process, the WCCP client sends a registration announcement (“Here I am”) every
10 seconds.
• The WCCP server (the Cisco router) accepts the registration request and acknowledges it with an “I See You”
WCCP message.
• The WCCP server waits 30 seconds before it declares the client as “inactive” (engine failed).
• Cisco WSA models:
- Cisco WSA S680
- Cisco WSA S670
- Cisco WSA S380
- Cisco WSA S370
- Cisco WSA S170
• WSA runs Cisco AsyncOS operating system that supports these features:
• Real-time antimalware adaptive scanning.
• Can be configured to dynamically select an antimalware scanning engine based on URL reputation, content type,
type,
• and
Layerscanner effectiveness.
4 traffic monitor.
• Used to detect and block spyware.
• It dynamically adds IP addresses of known malware domains to a database of sites to block.
• Third-party DLP integration.
• Redirects all outbound traffic to a third-party DLP appliance, allowing deep content inspection for regulatory
compliance and data exfiltration protection.
• Enables an administrator to inspect web content by title, metadata, and size.
• Can even prevent users from storing files to cloud services, such as Dropbox, Google Drive, and others.
CCNA Sec Page 88
• Can even prevent users from storing files to cloud services, such as Dropbox, Google Drive, and others.
• File reputation.
• Using threat information from Cisco Talos.
• This file reputation threat intelligence is updated every 3 to 5 minutes.
• File sandboxing.
• If malware is detected, the Cisco AMP capabilities can put files in a sandbox to inspect its behavior, combining
the inspection with machine-learning analysis to determine the threat level.
• File retrospection.
• After a malicious attempt or malware is detected, the Cisco WSA continues to cross-examine files over an
extended period of time.
• Application visibility and control.
• Allows the ASA to inspect and even block applications that are not allowed by the corporate security polity.
• Ex. an administrator can allow users to use social media sites like Facebook but block micro-applications
such as Facebook games.
• Cisco Cloud Web Security (CWS).
• A cloud-based security service from Cisco that provides worldwide threat intelligence, advanced threat defense
capabilities, and roaming user protection.
• Uses web proxies in Cisco’s cloud environment that scan traffic for malware and policy enforcement.
• Cisco customers can connect to the Cisco CWS service directly by using a proxy autoconfiguration (PAC) file in
the user endpoint.
• PAC is a file defines how web browsers and other user agents can automatically choose the appropriate proxy
server (access method) for fetching a given URL.
• Or through transparent connectors integrated into the following Cisco products:
- Cisco ISR G2 routers
- Cisco ASA
- Cisco WSA
- Cisco AnyConnect Secure Mobility Client
• SMA models:
- Cisco SMA M680: Designed for large organizations with over 10,000 users.
- Cisco SMAV M600v: Designed for large enterprises or service providers.
- Cisco SMA M380: Designed for organizations with 1000 to 10,000 users.
- Cisco SMAV M300v: Designed for organizations with 1000 to 5000 users.
- Cisco SMA M170: Designed for small business or branch offices w ith up to 1000 users.
- Cisco SMAV M100v: Designed for small business or branch offices with up to 1000 users.