-
-
Notifications
You must be signed in to change notification settings - Fork 5.2k
Cleaned up javascript code #4376
New issue
Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.
By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.
Already on GitHub? Sign in to your account
Conversation
1. Reused variable `emailList` which is best practice and easier to read 2. Removed `return false`. There is no use for it in this context and many consider it to be bad use as well. For example: http://fuelyourcoding.com/jquery-events-stop-misusing-return-false/
@@ -192,9 +192,7 @@ you need is the JavaScript: | |||
|
|||
// create a new list element and add it to the list | |||
var newLi = jQuery('<li></li>').html(newWidget); | |||
newLi.appendTo(jQuery('#email-fields-list')); | |||
|
|||
return false; |
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
now you removed return false
, you should add e.preventDefault()
on line 183 and an argument e
in the event listener callback.
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
Well i'm not sure the default does anything since it's an a href
with action #
. But i added it anyway ^^
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
I'm not sure of the benefit removing the return false
since it's more intuitive and easy to read than e.preventDefault()
and have in this context the same role... :o
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
They do not do the same thing. The PR description contains a link to an article about the differences.
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
I think e.preventDefault()
is easier, since its naming is clear about what it is doing: preventing the default behaviour. return false
might be intuitive to JS developers, but it clearly isn't if you aren't used to program in JavaScript.
Furthermore, using it is consistent with the jQuery examples in the form collections cookbook (I think we might need to make them even more consistent).
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
@flip111 to make the review complete, preventing the default is needed. Otherwise, the behavior of href="#"
will be to make your browser scroll to the top of the page
Thanks @flip111. |
This PR was squashed before being merged into the 2.3 branch (closes #4376). Discussion ---------- Cleaned up javascript code | Q | A | ------------- | --- | Doc fix? | yes | New docs? | no | Applies to | 2.3 | Fixed tickets | n/a 1. Reused variable `emailList` which is best practice and easier to read 2. Removed `return false`. There is no use for it in this context and many consider it to be bad use as well. For example: http://fuelyourcoding.com/jquery-events-stop-misusing-return-false/ Commits ------- 8931249 Cleaned up javascript code
emailList
which is best practice and easier to readreturn false
. There is no use for it in this context and many consider it to be bad use as well. For example: http://fuelyourcoding.com/jquery-events-stop-misusing-return-false/